Fieldpine Logo  

Browser Test Page

This page runs through a number of tests on your browser to verify it is broadly compatible with Fieldpine Point of Sale. More precise details of what that means is at the bottom of this page


You should not be able to see this message. If you can then either you have Javascript turned off or your browser does not support

getElementById
You cannot use Fieldpine Point of Sale.

You are viewing the features as supported by this browser. If required features are missing then Fieldpine cannot be used on this device. However, you may like to check if the device works when using a Polyfill

Checking...

Javascript Required Features

These features are all required or this browser will struggle with many pages

setTimeout

??

localStorage

??

sessionStorage

??

Promises

??

Await Promises

??

postMessage

??

Let/Var

??

Javascript Desirable Features

These features should be present to get maximum usability.

Fat Arrows

??

Indexed Db

??

Javascript Optional Features

These features are used in specific places and while not strictly currently needed are definitely nice to have, or may be required in the future

Cryptography

??
Cryptography support is sometimes used to securely store data in the browser. Mostly not having cryptography will mean you may not be able to access functionality without a working internet connection

GeoLocation

??
Geolocation is sometimes used to ensure devices are physically where they are meant to be. It helps protect against devices moving from store #1 to store #2 without being reconfigured

WebAssembly

??
WebAssembly is a different way of programming browsers and has several benefits, including permitting much more intelligence in the browser.

Serial Devices

??
Serial device access allows the browser to directly interact with some types of barcode scanners. If this is not present it means your scanners must be setup in an alternative manner

Visual Output

Date Input


??
Native date input uses the browser to enter dates which can be much more user friendly. Without this support users may need to type dates to the correct format

The next two blocks should be beside each other

One
Two

Optional Visual Output

These tests will show if your browser supports some extended visual features but will not stop you from using Fieldpine Point of Sale

The next two blocks should be beside each other, with rounded corners. One with a red shadow and the other with a green shadow

One
Uses px measurements
Two
Uses em measurements

Fieldpine Compatible?

When we say Fieldpine Compatible, this varies by how you wish to use Fieldpine

If you are using the latest versions on Chrome (desktop) or Edge (desktop) then you will have all the features required, except for the narrow case of using embedded web pages in PosGeen, which is rare

If you are using Internet Explorer, which probably implies you are on Windows 7 or older, then you may need to move your browsing to Chrome, or update Windows.

If you are using an up to date Chromebook, then it will have all required features.

Using Fieldpine supplied Web reports and Management functions

This requires full browser support

Mobile selling devices

In general this requires full browser support, although some limited functionality selling interfaces may not require all the features

Using Browser only selling at a checkout

This requires full browser support

Using PosGreen (Windows) at a checkout with embedded browsers

Does not require any advanced features unless the pages being viewed are Fieldpine standard management and report pages. This is rare.

Interaction by a retail customer device

Does not require any special features and will dynamically limit the capabilities to the device in use.

Interaction by a trade customer, supplier or other higher level of interaction

In general may require full browser support. The users in this group are typically using advanced features beyond simple interaction.

FAQ

Why does support vary?

Supporting old browsers is hard and time consuming. We are sure you would prefer that we work on new functionality and moving forward rather than working to support older devices. Some of this is also driven by how we build things, new tools we use expect new environments.

My device does offer all the features - what does this mean?

When a device does not offer native support of the features we attempt to load a polyfill to emulate those features for us. In the majority of cases this may make the device work. However, we do not provide in depth support for devices using polyfills.

You are loading external scripts? What about ....?

An external Polyfill is loaded from https://polyfill.io by web pages. This is a widely used and respected site. It does have it's own terms and conditions, privacy policies and cookie policy. You should read these statements on their website

If you are a high security site and do not wish to load external scripts into your web pages then

  1. Contact your Fieldpine representative to have them disable this loading
  2. Use only modern devices that do not require a polyfill
  3. Optionally, implement your own firewall block to the website polyfill.io This might affect other websites as well.